Friday, September 9, 2011

Rip Lab

Cisco Simple RIP Lab


HARDWARE REQUIREMENTS :
  1. Four 3600 series routers &  serial  cables

INTERFACE CONFIGURATION SUMMARY:

R1
E1/0
S0/0
S1/0
101.100.101.1
1.1.1.1
4.1.1.2
R2
E1/0
S0/0
S1/0
101.100.101.2
1.1.1.2
2.1.1.1
R3
E1/0
S0/0
S1/0
101.100.101.3
2.1.1.2
3.1.1.1
R2
E1/0
S0/0
S1/0
101.100.101.4
3.1.1.2
4.1.1.1



ROUTING INFORMATION PROTOCOL (RIP)

 

R1 Router Configuration


R1#configure  terminal
R1(config)#interface ethernet 1/0
R1(config-if)#ip address 101.100.101.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface serial 0/0
R1(config-if)#ip address 1.1.1.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#interface serial 0/1
R1(config-if)#ip address 4.1.1.2 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#clock rate 64000
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 1.0.0.0 (Advertise the network)
R1(config-router)#network 4.0.0.0
R1(config-router)#network 101.100.101.0

NOTE: To remove the protocol use no form of the command
For ex:

R1(config)#no router rip          (To disable rip routing process)
R1(config)#interface serial 0
R1(config-if)#no ip address     (To remove ip address from interface)


 












R2 Router Configuration:

R2#configure  terminal
R2(config)#interface ethernet 1/0
R2(config-if)#ip address 101.100.101.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#interface serial 0/0
R2(config-if)#ip address 1.1.1.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#interface serial 0/1
R2(config-if)#ip address 2.1.1.1 255.0.0.0
R2(config-if)#no shutdownR1(config-router)#no auto-summary
R2(config-router)#network 1.0.0.0 (Advertise the network)
R2(config-router)#network 2.0.0.0
R2(config-router)#network 101.100.102.0



R3 Router Configuration:

R3#configure  terminal
R3(config)#interface ethernet 1/0
R3(config-if)#ip address 101.100.101.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#interface serial 0/0
R3(config-if)#ip address 2.1.1.2 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#interface serial 0/1
R3(config-if)#ip address 3.1.1.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#clock rate 64000
R3(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R3(config-router)#network 2.0.0.0 (Advertise the network)
R3(config-router)#network 3.0.0.0
R3(config-router)#network 101.100.101.0

R4 Router Configuration:

R4#configure  terminal
R4(config)#interface ethernet 1/0
R4(config-if)#ip address 101.100.101.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#interface serial 0/0
R4(config-if)#ip address 3.1.1.2 255.0.0.0
R4(config-if)#no shutdown
R4(config-if)#interface serial 0/1
R4(config-if)#ip address 4.1.1.2 255.0.0.0
R4(config-if)#no shutdown
R4(config-if)#clock rate 64000
R4(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R4(config-router)#network 3.0.0.0 (Advertise the network)
R4(config-router)#network 4.0.0.0
R4(config-router)#network 101.100.101.0


VERIFICATION COMMANDS:
R1#show ip protocols
R1#show ip route
R1#debug ip rip

R1 Routing Table After RIPV2 Configuration:

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    1.0.0.0/8 is directly connected, Serial0/0
R    2.0.0.0/8 [120/1] via 1.1.1.2, 00:00:12, Serial0/0
R    3.0.0.0/8 [120/1] via 4.1.1.1, 00:00:19, Serial0/1
101.0.0.0/24 is subnetted, 4 subnets
C       101.100.101.0 is directly connected, Ethernet1/0
R       101.100.103.0 [120/2] via 4.1.1.1, 00:00:19, Serial0/1 [120/2] via 1.1.1.2, 00:00:12, Serial0/0
R       101.100.102.0 [120/1] via 1.1.1.2, 00:00:12, Serial0/0
R       101.100.104.0 [120/1] via 4.1.1.1, 00:00:19, Serial0/1
C    4.0.0.0/8 is directly connected, Serial0/1






R2 Routing Table After RIPV2 Configuration:
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    1.0.0.0/8 is directly connected, Serial0/0
C    2.0.0.0/8 is directly connected, Serial0/1
R    3.0.0.0/8 [120/1] via 2.1.1.2, 00:00:15, Serial0/1
101.0.0.0/24 is subnetted, 4 subnets
R       101.100.101.0 [120/1] via 1.1.1.1, 00:00:22, Serial0/0
R       101.100.103.0 [120/1] via 2.1.1.2, 00:00:15, Serial0/1
C       101.100.102.0 is directly connected, Ethernet1/0
R       101.100.104.0 [120/2] via 2.1.1.2, 00:00:15, Serial0/1 [120/2] via 1.1.1.1, 00:00:22, Serial0/0
R    4.0.0.0/8 [120/1] via 1.1.1.1, 00:00:23, Serial0/0






R3 Routing Table After RIPV2 Configuration:
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R    1.0.0.0/8 [120/1] via 2.1.1.1, 00:00:15, Serial0/0
C    2.0.0.0/8 is directly connected, Serial0/0
C    3.0.0.0/8 is directly connected, Serial0/1
101.0.0.0/24 is subnetted, 4 subnets
R       101.100.101.0 [120/2] via 3.1.1.2, 00:00:11, Serial0/1 [120/2] via 2.1.1.1, 00:00:15, Serial0/0
C       101.100.103.0 is directly connected, Ethernet1/0
R       101.100.102.0 [120/1] via 2.1.1.1, 00:00:15, Serial0/0
R       101.100.104.0 [120/1] via 3.1.1.2, 00:00:11, Serial0/1
R    4.0.0.0/8 [120/1] via 3.1.1.2, 00:00:13, Serial0/1




R4 Routing Table After RIPV2 Configuration:

R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R    1.0.0.0/8 [120/1] via 4.1.1.2, 00:00:00, Serial0/1
R    2.0.0.0/8 [120/1] via 3.1.1.1, 00:00:06, Serial0/0
C    3.0.0.0/8 is directly connected, Serial0/0
     101.0.0.0/24 is subnetted, 4 subnets
R       101.100.101.0 [120/1] via 4.1.1.2, 00:00:00, Serial0/1
R       101.100.103.0 [120/1] via 3.1.1.1, 00:00:06, Serial0/0
R       101.100.102.0 [120/2] via 4.1.1.2, 00:00:00, Serial0/1
                      [120/2] via 3.1.1.1, 00:00:06, Serial0/0
C       101.100.104.0 is directly connected, Ethernet1/0
C    4.0.0.0/8 is directly connected, Serial0/1








TROUBLE SHOOTING


Debugging of R1 (debug ip rip)
*Mar  1 04:23:23.018: RIP: sending v2 update to 224.0.0.9 via Ethernet1/0 (101.100.101.1)
*Mar  1 04:23:23.022: RIP: build update entries
*Mar  1 04:23:23.022:   1.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:23:23.026:   2.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:23:23.026:   3.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:23:23.030:   4.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:23:23.034:   101.100.102.0/24 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:23:23.034:   101.100.103.0/24 via 0.0.0.0, metric 3, tag 0
*Mar  1 04:23:23.038:   101.100.104.0/24 via 0.0.0.0, metric 2, tag 0
R1#
*Mar  1 04:23:25.742: RIP: sending v2 update to 224.0.0.9 via Serial0/1 (4.1.1.2)
*Mar  1 04:23:25.746: RIP: build update entries
*Mar  1 04:23:25.746:   1.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:23:25.750:   2.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:23:25.754:   101.100.101.0/24 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:23:25.754:   101.100.102.0/24 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:23:26.274: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (1.1.1.1)
*Mar  1 04:23:26.278: RIP: build update entries
*Mar  1 04:23:26.278:   3.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:23:26.282:   4.0.0.0/8 via 0.0.0.0, metric 1, tag 0
R1#
*Mar  1 04:23:26.282:   101.100.101.0/24 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:23:26.286:   101.100.104.0/24 via 0.0.0.0, metric 2, tag 0
R1#
*Mar  1 04:23:31.426: RIP: received v2 update from 4.1.1.1 on Serial0/1
*Mar  1 04:23:31.430:      2.0.0.0/8 via 0.0.0.0 in 2 hops
*Mar  1 04:23:31.434:      3.0.0.0/8 via 0.0.0.0 in 1 hops
*Mar  1 04:23:31.434:      101.100.103.0/24 via 0.0.0.0 in 2 hops
*Mar  1 04:23:31.438:      101.100.104.0/24 via 0.0.0.0 in 1 hops
R1#
*Mar  1 04:23:45.038: RIP: received v2 update from 1.1.1.2 on Serial0/0
*Mar  1 04:23:45.042:      2.0.0.0/8 via 0.0.0.0 in 1 hops
*Mar  1 04:23:45.042:      3.0.0.0/8 via 0.0.0.0 in 2 hops
*Mar  1 04:23:45.046:      101.100.102.0/24 via 0.0.0.0 in 1 hops
*Mar  1 04:23:45.046:      101.100.103.0/24 via 0.0.0.0 in 2 hop




0.0.0.0 is actually a null value.  If you look at rfc2453 (rip v2), you will find the following.

The immediate next hop IP address to which packets to the destination specified by this route entry should be forwarded.  Specifying a value of 0.0.0.0 in this field indicates that routing should be via the originator of the RIP advertisement.  An address specified as a next hop must, per force, be directly reachable on the logical subnet over which the advertisement is made.

This means 0.0.0.0 is actually just a null value and thus the source IP in the RIPv2's IP header is used as the originator of the IP route.


 
 

















Debugging of R2 (debug ip rip)
*Mar  1 04:25:48.570: RIP: sending v2 update to 224.0.0.9 via Serial0/1 (2.1.1.1)
*Mar  1 04:25:48.574: RIP: build update entries
*Mar  1 04:25:48.574:   1.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:25:48.574:   4.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:25:48.574:   101.100.101.0/24 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:25:48.574:   101.100.102.0/24 via 0.0.0.0, metric 1, tag 0
R2#
*Mar  1 04:25:58.962: RIP: sending v2 update to 224.0.0.9 via Ethernet1/0 (101.100.102.1)
*Mar  1 04:25:58.966: RIP: build update entries
*Mar  1 04:25:58.966:   1.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:25:58.970:   2.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:25:58.970:   3.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:25:58.970:   4.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:25:58.974:   101.100.101.0/24 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:25:58.974:   101.100.103.0/24 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:25:58.974:   101.100.104.0/24 via 0.0.0.0, metric 3, tag 0
*Mar  1 04:25:59.802: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (1.1.1.2) R2#
*Mar  1 04:25:59.806: RIP: build update entries
*Mar  1 04:25:59.806:   2.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:25:59.806:   3.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:25:59.806:   101.100.102.0/24 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:25:59.806:   101.100.103.0/24 via 0.0.0.0, metric 2, tag 0
R2#
*Mar  1 04:26:10.358: RIP: received v2 update from 1.1.1.1 on Serial0/0
*Mar  1 04:26:10.358:      3.0.0.0/8 via 0.0.0.0 in 2 hops
*Mar  1 04:26:10.362:      4.0.0.0/8 via 0.0.0.0 in 1 hops
*Mar  1 04:26:10.362:      101.100.101.0/24 via 0.0.0.0 in 1 hops
*Mar  1 04:26:10.366:      101.100.104.0/24 via 0.0.0.0 in 2 hops
R2#
*Mar  1 04:26:12.014: RIP: received v2 update from 2.1.1.2 on Serial0/1
*Mar  1 04:26:12.014:      3.0.0.0/8 via 0.0.0.0 in 1 hops
*Mar  1 04:26:12.018:      4.0.0.0/8 via 0.0.0.0 in 2 hops
*Mar  1 04:26:12.018:      101.100.103.0/24 via 0.0.0.0 in 1 hops
*Mar  1 04:26:12.022:      101.100.104.0/24 via 0.0.0.0 in 2 hops



Debugging of R3 (debug ip rip)

Mar   1 04:19:09.702: RIP: sending v2 update to 224.0.0.9 via Ethernet1/0 (101.100.103.1)
*Mar  1 04:19:09.706: RIP: build update entries
*Mar  1 04:19:09.706:   1.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:19:09.710:   2.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:19:09.710:   3.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:19:09.714:   4.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:19:09.718:   101.100.101.0/24 via 0.0.0.0, metric 3, tag 0
*Mar  1 04:19:09.718:   101.100.102.0/24 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:19:09.722:   101.100.104.0/24 via 0.0.0.0, metric 2, tag 0
R3#
*Mar  1 04:19:14.854: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (2.1.1.2)
*Mar  1 04:19:14.858: RIP: build update entries
*Mar  1 04:19:14.858:   3.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:19:14.862:   4.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:19:14.866:   101.100.103.0/24 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:19:14.866:   101.100.104.0/24 via 0.0.0.0, metric 2, tag 0
R3#
*Mar  1 04:19:16.914: RIP: sending v2 update to 224.0.0.9 via Serial0/1 (3.1.1.1)
*Mar  1 04:19:16.918: RIP: build update entries
*Mar  1 04:19:16.918:   1.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:19:16.918:   2.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:19:16.918:   101.100.102.0/24 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:19:16.918:   101.100.103.0/24 via 0.0.0.0, metric 1, tag 0
R3#
*Mar  1 04:19:19.874: RIP: received v2 update from 2.1.1.1 on Serial0/0
*Mar  1 04:19:19.878:      1.0.0.0/8 via 0.0.0.0 in 1 hops
*Mar  1 04:19:19.882:      4.0.0.0/8 via 0.0.0.0 in 2 hops
*Mar  1 04:19:19.882:      101.100.101.0/24 via 0.0.0.0 in 2 hops
*Mar  1 04:19:19.886:      101.100.102.0/24 via 0.0.0.0 in 1 hops
R3#
*Mar  1 04:19:23.038: RIP: received v2 update from 3.1.1.2 on Serial0/1
*Mar  1 04:19:23.038:      1.0.0.0/8 via 0.0.0.0 in 2 hops
*Mar  1 04:19:23.042:      4.0.0.0/8 via 0.0.0.0 in 1 hops
*Mar  1 04:19:23.042:      101.100.101.0/24 via 0.0.0.0 in 2 hops
*Mar  1 04:19:23.046:      101.100.104.0/24 via 0.0.0.0 in 1 hops



Debugging of R4 (debug ip rip)

*Mar  1 04:34:58.354: RIP: sending v2 update to 224.0.0.9 via Serial0/0 (3.1.1.2)
*Mar  1 04:34:58.354: RIP: build update entries
*Mar  1 04:34:58.354:   1.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:34:58.358:   4.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:34:58.362:   101.100.101.0/24 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:34:58.362:   101.100.104.0/24 via 0.0.0.0, metric 1, tag 0
R4#
*Mar  1 04:35:04.278: RIP: sending v2 update to 224.0.0.9 via Serial0/1 (4.1.1.1)
*Mar  1 04:35:04.282: RIP: build update entries
*Mar  1 04:35:04.282:   2.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:35:04.286:   3.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:35:04.290:   101.100.103.0/24 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:35:04.290:   101.100.104.0/24 via 0.0.0.0, metric 1, tag 0
R4#
*Mar  1 04:35:06.778: RIP: received v2 update from 3.1.1.1 on Serial0/0
*Mar  1 04:35:06.778:      1.0.0.0/8 via 0.0.0.0 in 2 hops
*Mar  1 04:35:06.782:      2.0.0.0/8 via 0.0.0.0 in 1 hops
*Mar  1 04:35:06.782:      101.100.102.0/24 via 0.0.0.0 in 2 hops
*Mar  1 04:35:06.786:      101.100.103.0/24 via 0.0.0.0 in 1 hops
R4#
*Mar  1 04:35:11.998: RIP: sending v2 update to 224.0.0.9 via Ethernet1/0 (101.100.104.1)
*Mar  1 04:35:12.002: RIP: build update entries
*Mar  1 04:35:12.002:   1.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:35:12.006:   2.0.0.0/8 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:35:12.006:   3.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:35:12.010:   4.0.0.0/8 via 0.0.0.0, metric 1, tag 0
*Mar  1 04:35:12.014:   101.100.101.0/24 via 0.0.0.0, metric 2, tag 0
*Mar  1 04:35:12.014:   101.100.102.0/24 via 0.0.0.0, metric 3, tag 0
*Mar  1 04:35:12.018:   101.100.103.0/24 via 0.0.0.0, metric 2, tag 0
R4#
*Mar  1 04:35:19.810: RIP: received v2 update from 4.1.1.2 on Serial0/1
*Mar  1 04:35:19.810:      1.0.0.0/8 via 0.0.0.0 in 1 hops
*Mar  1 04:35:19.814:      2.0.0.0/8 via 0.0.0.0 in 2 hops
*Mar  1 04:35:19.814:      101.100.101.0/24 via 0.0.0.0 in 1 hops
*Mar  1 04:35:19.818:      101.100.102.0/24 via 0.0.0.0 in 2 hops